Back
May 14, 20261 hour ago
CDN

CDN Latency Issue Identified

Resolved·May 14, 2026 at 8:07 PM·Resolved in 24 min
The CDN issue has been resolved. The recent DDoS attack has stopped, and the new protection layers are active.
Monitoring·May 14, 2026 at 8:01 PM

We have completed the CDN migration and added new protection layers to help mitigate the recent DDoS attack. The attack traffic has now stopped, and CDN services are recovering across affected regions.

Our team is actively monitoring CDN performance, regional routing, cache health, and asset delivery for scripts, images, and other static files to ensure the service remains stable.

CDNDegraded PerformanceOperational
Identified·May 14, 2026 at 7:44 PM
We have mitigated the regional CDN outage caused by a large-scale DDoS attack. A fallback delivery system has been activated for affected regions to keep scripts, images, and other static assets available.

Some users may still experience **increased loading times** for script files, images, and cached content while traffic is routed through the fallback system. Our team is continuing to monitor CDN performance, regional routing, and attack traffic.